Monday, May 21, 2018

VMWare 14.1.1 and Fedora 28 woes fixed!

Hi there. This is just a quick note on how to make VMWare Workstation 14.1.1 run properly on Fedora 28. I didn't figure these out myself so thanks to the original posters.

First off, right after installation VMWare cannot compile the kernel modules it needs to work. To fix this you'll need to install a package, make a sym link and reconfigure VMWare. You can also install the package and make the symlink BEFORE installing VMWare  to cut out the final command.

# dnf install elfutils-libelf-devel
# cp /usr/include/linux/version.h /lib/modules/$(uname -r)/build/include/linux/
# vmware-modconfig --console --install-all

Next up is 3D acceleration support. If you're using a nVidia card and their binary drivers you're good to go. But, if you're using MESA for 3D acceleration you'll need to add a line to your virtual machine's .vmx file. I just added it to the bottom of the file and all was well. Make sure VMWare is not running when you edit the .vmx file or it will over write your change when you shut it down.

mks.gl.allowBlacklistedDrivers = "TRUE

These were the only fixes I needed to make VMWare Workstation 14.1.1 functional on Fedora 28. In future releases of VMWare you might not need to do these fixes. I hope this helps and happy vm'ing.

Virtualbox and Fedora 28 Linux install error

I was messing with installing Virtualbox 5.2.18 this morning. Upon attempting to compile the needed kernel modules I was given errors. As it...